home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / ipw2100-1.2.1-r1 / ipw2100-1.2.1-r1.ebuild < prev    next >
Text File  |  2006-05-11  |  3KB  |  98 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw2100/ipw2100-1.2.1-r1.ebuild,v 1.3 2006/04/22 14:41:58 brix Exp $
  4.  
  5. inherit eutils linux-mod
  6.  
  7. # The following works with both pre-releases and releases
  8. MY_P=${P/_/-}
  9. S=${WORKDIR}/${MY_P}
  10.  
  11. IEEE80211_VERSION="1.1.12"
  12. FW_VERSION="1.3"
  13.  
  14. DESCRIPTION="Driver for the Intel PRO/Wireless 2100 3B miniPCI adapter"
  15. HOMEPAGE="http://ipw2100.sourceforge.net"
  16. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
  17.  
  18. LICENSE="GPL-2"
  19. SLOT="0"
  20. KEYWORDS="x86"
  21.  
  22. IUSE="debug"
  23. DEPEND=">=net-wireless/ieee80211-${IEEE80211_VERSION}"
  24. RDEPEND="${DEPEND}
  25.         =net-wireless/ipw2100-firmware-${FW_VERSION}
  26.         >=net-wireless/wireless-tools-27_pre23"
  27.  
  28. BUILD_TARGETS="all"
  29. MODULE_NAMES="ipw2100(net/wireless:)"
  30. MODULESD_IPW2100_DOCS="README.ipw2100"
  31.  
  32. CONFIG_CHECK="NET_RADIO FW_LOADER !IPW2100"
  33. ERROR_NET_RADIO="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
  34. ERROR_FW_LOADER="${P} requires Hotplug firmware loading support (CONFIG_FW_LOADER)."
  35. ERROR_IPW2100="${P} requires the in-kernel version of the IPW2100 driver to be disabled (CONFIG_IPW2100)"
  36.  
  37. pkg_setup() {
  38.     linux-mod_pkg_setup
  39.  
  40.     if kernel_is 2 4; then
  41.         die "${P} does not support building against kernel 2.4.x"
  42.     fi
  43.  
  44.     if [[ ! -f ${ROOT}/lib/modules/${KV_FULL}/net/ieee80211/ieee80211.${KV_OBJ} ]]; then
  45.         eerror
  46.         eerror "Looks like you forgot to remerge net-wireless/ieee80211 after"
  47.         eerror "upgrading your kernel."
  48.         eerror
  49.         eerror "Hint: use sys-kernel/module-rebuild for keeping track of which"
  50.         eerror "modules needs to be remerged after a kernel upgrade."
  51.         eerror
  52.         die "${ROOT}/lib/modules/${KV_FULL}/net/ieee80211/ieee80211.${KV_OBJ} not found"
  53.     fi
  54.  
  55.     BUILD_PARAMS="KSRC=${KV_DIR} KSRC_OUTPUT=${KV_OUT_DIR} IEEE80211_INC=/usr/include"
  56. }
  57.  
  58. src_unpack() {
  59.     local debug="n"
  60.  
  61.     unpack ${A}
  62.  
  63.     cd ${S}
  64.     epatch ${FILESDIR}/${P}-cflags.patch
  65.  
  66.     use debug && debug="y"
  67.     sed -i -e "s:^\(CONFIG_IPW2100_DEBUG\)=.*:\1=$debug:" ${S}/Makefile
  68. }
  69.  
  70. src_compile() {
  71.     linux-mod_src_compile
  72.  
  73.     einfo
  74.     einfo "You may safely ignore any warnings from above compilation about"
  75.     einfo "undefined references to the ieee80211 subsystem."
  76.     einfo
  77. }
  78.  
  79. src_install() {
  80.     linux-mod_src_install
  81.  
  82.     dodoc CHANGES
  83. }
  84.  
  85. pkg_postinst() {
  86.     linux-mod_pkg_postinst
  87.  
  88.     if [ -f /lib/modules/${KV_FULL}/net/${PN}.ko ]; then
  89.         einfo
  90.         einfo "Modules from an earlier installation detected. You will need to manually"
  91.         einfo "remove those modules by running the following commands:"
  92.         einfo "  # rm -f /lib/modules/${KV_FULL}/net/${PN}.ko"
  93.         einfo "  # rm -f /lib/modules/${KV_FULL}/net/ieee80211*.ko"
  94.         einfo "  # depmod -a"
  95.         einfo
  96.     fi
  97. }
  98.